Get in touch
Back
Maintenance

Maintenance

Completed 14 Oct at 08:30am CEST.

https://paywithterra.com PaywithTerra API
Completed

Maintenance completed

Posted 14 Oct at 08:30am CEST.
Started

Rolling out system updates

Posted 14 Oct at 08:00am CEST.